Instantly Dismantled Tower

This forum is for reporting bugs or glitches found in equipment (Inventory Items). Please use the kind of equipment name in the topic title with description, titles with only "found a bug", "bug" and alike will be deleted.
Example title: Muzzleloader, Red Deer Caller.
User avatar
Posts: 817
Joined: April 28th, 2010, 9:48 am

Instantly Dismantled Tower

Postby TheSheWolf » June 7th, 2018, 2:23 pm

Issue: A hunting tower was instantly dismantled. The tooltip still says it takes 48 hours to dismantle, but both were placed into my inventory and I subsequently placed both on my map.

Details: While redoing my TgT setup, I had a Deployable Hunting Tower - Bare Wood in the inventory. I had another Bare Wood tower set up already but wanted to move it about 100 yards away. First, I chose a location for the new tower. I placed it. I immediately realized I didn't want it where it was, so I went to Cancel Construction. While I waited for it to complete from 99%, I ran over to the already-completed tower, and set this one to deconstruct. At this point the screen faded to black but took an unusually long time to come back. When it did, the already-completed tower (there for months) was already dismantled and in my inventory. The other was no longer visible on the map either. Neither could be placed, but upon closing and rejoining the same map, both were in my inventory and could be placed.

To try to reproduce:

1. Have a completed tower on a map (Tower A).
2. Have a second tower in inventory (Tower B).
3. Place Tower B, wait a moment, and then choose Cancel Construction.
4. Go to Tower A, and choose to Deconstruct it.

I would test it further myself, but given the setup time it isn't really viable for a player to do.
User avatar
Posts: 1613
Joined: December 6th, 2015, 1:39 pm

Re: Instantly Dismantled Tower

Postby RidgeBack69 » June 8th, 2018, 8:30 am

Not that I want to see this fixed but the steps to reproduce are a bit differnt than TheSheWolf explains.

To reproduce simply walk to the tool box and
press E
select dismantle. and the tower will be dismantled instantly.
User avatar
Posts: 4710
Joined: October 11th, 2013, 3:36 pm
Location: Montreal, Quebec, Canada

Re: Instantly Dismantled Tower

Postby DYEUZ » June 12th, 2018, 1:35 pm

Here is what i found , about a possible bugged constructible tower .

Game : SP
Reserve : LP

What happened :
- Wanted to put up a tower somewhere .
- Found a couple possible spots close to each other . So started to check them out .
- Put up a tower . Saw the bundle appear . Decided to check other spot . So canceled construction . Elapsed time 10-15 seconds .
- Tried another spot . Saw the white tower , click to put down , no tower to be seen . I still had the papers in my hand.
- At bottom right corner of screen , the mention '' construction 0% '' was visible .
- Tried couple more places to test this and was doing the same .
- Tower was in inventory of backpack though .

Seems the tower is visible only on your first attempt and only then can you start the construction .

Steps to reproduce :
- Just repeat '' what happened '' .

User avatar
Trophy Hunter
Posts: 6612
Joined: November 29th, 2008, 5:55 am
Location: Idaho, U.S.A.

Re: Instantly Dismantled Tower

Postby Grizdude » June 12th, 2018, 2:36 pm

RidgeBack69 wrote:Not that I want to see this fixed but the steps to reproduce are a bit differnt than TheSheWolf explains.

To reproduce simply walk to the tool box and
press E
select dismantle. and the tower will be dismantled instantly.

I tried this and I can confirm that it works.
User avatar
Posts: 231
Joined: May 8th, 2016, 4:52 pm

Re: Instantly Dismantled Tower

Postby Reggy » June 16th, 2018, 1:29 pm

First this only happens for me on the GREEN towers. I ran into this on WRR, instantly deconstructed 2 towers and placed them in the backpack. You choose deconstruct, get black screen, ESC to main menu, ESC back to game. Tried to set up 1 and got the white outline clicked and white outline gone but no tower. Tried to setup a plain wood tower had no problems. Quickly stopped the wood tower and tried to place again, 2nd time no problems. About 3.5 in-games hours later I tried the green again and it worked, but once I canceled it I could not setup another greed tower. Could this be tied to the wobble in the green towers? I don't get wobble in any other tower. Below are some Steam screenshots showing setting up, working & not working. Hope they help.
Green tower - ... 1412942480
Same tower after deconstruct - ... 1412942520
Green tower try to place - ... 1412942569
Same tower results - ... 1412942600
Plain wood tower place - ... 1412942821
Plain wood results - ... 1412942838

Time is visible in the HM and I didn't move when placing the green or wood tower. Green failed, wood worked both same place.
Season Stats:


Return to “Equipment / Gear”

Who is online

Users browsing this forum: No registered users and 1 guest