Can't Equip Scope

Have a problem? Not sure what to do? Check here for helpful answers. Please Read the Guides First :D
User avatar
Diskid86
Newbie
Posts: 20
Joined: May 6th, 2017, 9:12 am
Location: USA

Can't Equip Scope

Postby Diskid86 » August 4th, 2018, 5:38 pm

I tried to start a hunt in Redfeather Falls to start the summer event's first quest for moose hunting.

I equipped my weapon of choice, the bullets, and when I got to the scope, no matter how many times I clicked on it - it wouldn't add to my equipment. I tried different guns and none of my scopes would "attach". I ended up just quitting and not even doing the hunt.
User avatar
VonStratos
Outfitter
Posts: 1300
Joined: February 7th, 2013, 6:32 pm

Re: Can't Equip Scope

Postby VonStratos » August 4th, 2018, 7:26 pm

It would help to know what weapon was and what scope, not every scope is compatible with every weapon. ;)

Image
Signature Stats

"Turkeys...the only animal smarter than man."

Return to “Need help? Support & Technical Issues”

Who is online

Users browsing this forum: No registered users and 1 guest